Announcement

Collapse
No announcement yet.

Improve EAX effects in BF2!! (finally)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Improve EAX effects in BF2!! (finally)

    Thanks to Alexs3ds from the Creative forums, there is a way to improve the EAX effects in-game for those of us with Audigy 1 and Audigy 2 cards. X-Fi owners have a nice little applet for altering EAX effects for games and will not need this.

    In this directory: c:\Program Files\EA Games\Battlefield 2\mods\bf2\Settings
    look for the file sound.con and edit it as follows:

    change this section:
    Code:
    rem ** Balance between 2d and 3d samples.
    sound.setProperty "balance2d3d-default" 0.5
    sound.setProperty "balance2d3d-eax" 0.5
    
    rem ** Reverb and obstruction
    vars.set sound-maxreverb 1
    vars.set sound-reverb-steepness 0.55
    vars.set sound-raylength 17
    to look like this:

    Code:
    rem ** Balance between 2d and 3d samples.
    sound.setProperty "balance2d3d-default" 0.8
    sound.setProperty "balance2d3d-eax" 0.8
    
    rem ** Reverb and obstruction
    vars.set sound-maxreverb 3
    vars.set sound-reverb-steepness 1
    vars.set sound-raylength 17
    If you find the sound of your own guns firing to be a bit too quiet compared to other sounds, then edit the balance2d3d settings to your liking where 0.5 is default, and 1 mutes all of your direct weapon effect sounds.

  • #2
    Re: Improve EAX effects in BF2!! (finally)

    Unfortunately i have an audigy 2 Value card and those drivers wont work with my pos card.

    Comment


    • #3
      Re: Improve EAX effects in BF2!! (finally)

      You don't need any special drivers for this. You just have to have Hardware enabled and EAX enabled.

      If your current card/driver combo will not allow you to use Hardware and EAX, then you should look into that first before attempting this.

      This has nothing to do with the OpenAL wrapper or beta or X-Fi drivers.

      This is a simple file edit.

      Comment


      • #4
        Re: Improve EAX effects in BF2!! (finally)

        EAX works thats why i bought it. It supports EAX advanced HD and 5.1 6.1 and 7.1 sound. Only thing is if someone has that Open AL file i would like to have it sent to me since the link to that file is invalid. Someone posted a thread about it 600% performance incrase when switching an open AL file. Actually i just found out that the X-Fi sound card at circuitcity.com is $199. Its the plantium edition.

        Comment


        • #5
          Re: Improve EAX effects in BF2!! (finally)

          Sorry...the fixes I am proposing in THIS thread are found much further down in the linked thread. I understand that the first post in that thread discusses the much debated OpenAL file switch..which I currently do NOT use.

          This thread is for those of us who find the EAX effects rather weak and want a simple file edit rather than a complicated driver combination.

          Comment


          • #6
            Re: Improve EAX effects in BF2!! (finally)

            Ill have to try that fix thx talus.

            Comment


            • #7
              Re: Improve EAX effects in BF2!! (finally)

              The best way to hear the difference is to stand inside a buliding and listen to the sounds around you.

              e.g. guns firing outside, tanks rolling buy, explosions in the distance

              Then walk OUTSIDE of the building and you'll be amazed by the transition.

              Unfortunately, the EAX effects applied to your own weapons in first person view are barely audible no matter what you do.

              So...load up a single player map or head online. Don't load up an empty server and expect to hear anything spectacular.

              Comment


              • #8
                Re: Improve EAX effects in BF2!! (finally)

                Anyone have that open AL file? Since the link doesnt work from the creative website.

                Comment


                • #9
                  Re: Improve EAX effects in BF2!! (finally)

                  Originally posted by DeathGiver
                  Anyone have that open AL file? Since the link doesnt work from the creative website.

                  You meanthis link,

                  http://developer.creative.com/articl...&top=38&aid=46

                  P.S. Google is your friend ,

                  http://www.google.com/search?sourcei...=utf8&q=openal

                  Comment


                  • #10
                    Re: Improve EAX effects in BF2!! (finally)

                    Connection was refused when trying to contact 216.61.164.51

                    Comment


                    • #11
                      Re: Improve EAX effects in BF2!! (finally)

                      Sounds like a problem on your end. I just downloaded that file from there about 10 minutes before posting the link.

                      Comment


                      • #12
                        Re: Improve EAX effects in BF2!! (finally)

                        Stupid windows Firewall

                        Comment


                        • #13
                          Re: Improve EAX effects in BF2!! (finally)

                          I agree...stupid windows firewall. I turned mine off. I prefer ZoneAlarm.

                          Comment


                          • #14
                            Re: Improve EAX effects in BF2!! (finally)

                            I dont see my windows/system 32 folder on my computer anywhere. I wanted to change the BF2 open AL from the open AL i downloaded.

                            Comment


                            • #15
                              Re: Improve EAX effects in BF2!! (finally)

                              Go to the Start menu
                              select 'Run'
                              type in:
                              Code:
                              C:\windows\system32
                              and hit enter

                              That should take you there.

                              System folders are hidden by default.

                              If you want to see them, load up windows explorer, go to 'Tools', then 'Folder Options', then click on the 'View' tab and check off 'Show Hidden Files and Folders'.

                              Comment

                              Working...
                              X