Announcement

Collapse
No announcement yet.

which patches do i need.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • which patches do i need.

    do I need all the patches, or just a couple of them to get up to date.
    can someone quickly tell me the ones I need. thank you

  • #2
    Re: which patches do i need.

    Just need Patch 1.12 for now.

    http://www.ea.com/official/battlefie.../downloads.jsp

    Comment


    • #3
      Re: which patches do i need.

      Comment


      • #4
        Re: which patches do i need.

        You always only ever need the latest patch.

        Comment

        Working...
        X