Announcement

Collapse
No announcement yet.

OMG, Stupid choking/choppy-ness

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OMG, Stupid choking/choppy-ness

    Okay, I've had BF2 for over a year now. It's a kickass game but I'm so pissed because for the last year before patch 1.4 or w/e the last one was the game ran completely fine.

    Yes, I'd get alittle 'LAG' if alot of effects were on screen. But, I never had this problem before. I don't get any 'LAG' now, but I do get tons of 'choking/choppy-ness'. Basically by 'LAG' I mean the image would show but go really slow, or the game would have low FPS. By 'CHOKING' I mean it's stopping all images for a second, then quickly "refreshing" and showing the new image. So I'll be walking then it seems like I've stopped (Nothing on screen moves) then it loads again and I'm were I would have been walking to. I hope this makes sense.

    And like I said before the patch the game ran great if I had the right video settings. Not only have I not changed my settings (Higher) but I have lowered them and the 'CHOKING' does not go away. Also, I've gotten a BETTER internet connection since then and it had no effect. My original connection was 3MB Down, 300KB Up. Now it's 10MB Down, 1MB Up. Also my ping is almost always great anywhere from 10-150 depending on the server. But, no matter what server I join it still has this weird 'choppy-ness'

    I run a 3.2ghz pentium 4
    2gb ram
    Radeon 700x
    10MB Cable/Fiber Optic. connection.

    Edit: I forgot to add that I've updated punkbuster and removed the intro movies for BF2. I just did that today to try and fix it, but it didn't fix anything. FYI (Some other forums asked if this had been done in similar posts)

  • #2
    Re: OMG, Stupid choking/choppy-ness

    You can always try defragmenting your HDs and/or formatting them.
    Can you by the way clarify your graphic card name? 700x?

    Comment


    • #3
      Re: OMG, Stupid choking/choppy-ness

      Yeah it's a ATI Radeon 700x. That's all I can tell you really heh.

      Comment


      • #4
        Re: OMG, Stupid choking/choppy-ness

        I think he means a x700 bro lol.

        Comment


        • #5
          Re: OMG, Stupid choking/choppy-ness

          might be worth a shot i had a similar problem and it was my cpu overheating i cleaned out the dust and it fixed the problem...good luck.

          Comment


          • #6
            Re: OMG, Stupid choking/choppy-ness

            you got a virus spyware ? have a look for them, also download, c cleaner and run'

            Comment


            • #7
              Re: OMG, Stupid choking/choppy-ness

              I have the EXACT same problem, and the thing is, it didn't start until like a day ago. I'm also pretty sure that nothing is overheating because I have a fan right next to my comp blowing inside. Anyone know what to do?

              My Specs:
              AMD Athlon XP 2800+
              1 gig of RAM
              Geforce 6600 256MB
              93.71 drivers (latest ones)

              Originally posted by defcon
              might be worth a shot i had a similar problem and it was my cpu overheating i cleaned out the dust and it fixed the problem...good luck.
              Well, I did that and it didn't really help and I also did a number of other things. I checked my adware,spyware, virus, registry mechanic, turned off shadows and light and it still skips. Would reinstalling Battlefield 2 help solve the problem. I also downloaded some older drivers.

              Comment


              • #8
                Re: OMG, Stupid choking/choppy-ness

                bump, reinstalled BF2 but this still has not fixed it does anyone know what to do at all?

                Comment


                • #9
                  Re: OMG, Stupid choking/choppy-ness

                  I know exactly how to fix the problem, because I also have an X700 Pro. Simply follow Tip 4 on page 2 of bf2lags Top Tweaks, found here:

                  http://www.bf2lag.com/page2.html

                  It deals with setting BF2 at a certain priority level. Now, it says to put it at high, but that made it worse (for me) and so I put it at low. Since you guys have the same graphics card, you may have to set it to low like I did. This ended all my lag problems not related to internet connections, it worked so well I do it with all my other games.

                  Comment


                  • #10
                    Re: OMG, Stupid choking/choppy-ness

                    Originally posted by Nefarious
                    I know exactly how to fix the problem, because I also have an X700 Pro. Simply follow Tip 4 on page 2 of bf2lags Top Tweaks, found here:

                    http://www.bf2lag.com/page2.html

                    It deals with setting BF2 at a certain priority level. Now, it says to put it at high, but that made it worse (for me) and so I put it at low. Since you guys have the same graphics card, you may have to set it to low like I did. This ended all my lag problems not related to internet connections, it worked so well I do it with all my other games.
                    Well I did what it said and i put all my settings on medium and it still jerked around a lot. When it says put it on low what does it mean, the settings or something else?

                    Comment


                    • #11
                      Re: OMG, Stupid choking/choppy-ness

                      its talking about the process priority that the game is running at, not the gfx settings

                      Comment


                      • #12
                        Re: OMG, Stupid choking/choppy-ness

                        Originally posted by masterllama
                        Well I did what it said and i put all my settings on medium and it still jerked around a lot. When it says put it on low what does it mean, the settings or something else?
                        When you edit the bat file put this instead:

                        @echo off
                        cd /d "C:\Program Files\EA GAMES\Battlefield 2"
                        start /low BF2.exe +menu 1 +fullscreen 1


                        Notice how I changed it from high to low.

                        Comment


                        • #13
                          Re: OMG, Stupid choking/choppy-ness

                          Originally posted by Nefarious
                          When you edit the bat file put this instead:

                          @echo off
                          cd /d "C:\Program Files\EA GAMES\Battlefield 2"
                          start /low BF2.exe +menu 1 +fullscreen 1


                          Notice how I changed it from high to low.
                          Heh well I have pretty much tried everything and I guess i'll just have to reformat my harddrive.

                          Comment


                          • #14
                            Re: OMG, Stupid choking/choppy-ness

                            Originally posted by masterllama
                            Heh well I have pretty much tried everything and I guess i'll just have to reformat my harddrive.
                            What? No. You dont have to do that, did you try Tip 4?

                            Comment


                            • #15
                              Re: OMG, Stupid choking/choppy-ness

                              Originally posted by Nefarious
                              What? No. You dont have to do that, did you try Tip 4?
                              Yep and its still fing choppy as hell!:cry:

                              Comment

                              Working...
                              X