Announcement

Collapse
No announcement yet.

unable to select xfi in audio options

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    TRY THIS....GO TO START>ALL PROGS>CREATIVE>MODE SWITCHER

    make sure the x fi card is not in music cration mode ..make sure the toggle switch is in game mode..start bf2 go into audio and set it to hardware and see if it detects the xfi.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    On the creative website the latest x fi patch mentions fixing problems for BF2 v1.12 ..... so I don't know whether or not 1.3 is covered.

    I actually attempted to remove bf2, install the lastest creative drivers, and reinstall bf2 in the hope that maybe the reinstall would pick up on the presence of the fatality card.

    Sadly this didn't work - it still says in BF2 Audio options when I attempt to select x-fi that my hardware doesn't support this option. I can select the hardware option though, so it recognises that there is something there.... (maybe - I don't have another system with no sound card to test whether that option is there regardless)


    All the music creation that I do on the card seems to work fine (these are pretty versatile cards creative released, which is why I got one over an emu) but this game doesn't seem to recognise the card is there. And I know this because of the sampling rates etc etc

    Any other suggestions?

    Ah, sorry missed Bludos reply on the second page - I'll try reinstalling the creative drivers.

    Leave a comment:


  • bludothesmelly
    replied
    Re: unable to select xfi in audio options

    Thanks guys, i ended up having to just reinstall the creative driver then bam came up. Why is it so paranoid by one little measily chipset driver change?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    im not sure the new creative driver fixes this prob but it does allow ultra high to be selected.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    I had the same issues. Download the latest drivers from Creative as there is a BF2 fix.

    Leave a comment:


  • disfigured
    replied
    Re: unable to select xfi in audio options

    Originally posted by bludothesmelly
    no regular headphones not usb
    It was a longshot. You don't sound like someone who wouldn't know this right off the bat, but I figured since the symptoms were nearly identical I'd throw it out there, just in case.

    Good Luck with a fix.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    hmm. i did have this problem before. realized that it was becos i had changed it to other modes before. since then i have always kept it at game mode and never changed it. changing mode frequently kinda causes bf2 to be unable to recognise your card and allow x-fi settings.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    By chance did you have a different soundblaster card installed on this computer, then upgrade to the xFi? If so there is a Knowledge base artical on this. I had the same thing happen to me. Here is the link: http://dmzweb3.europe.creative.com/S...ww_english_add

    Leave a comment:


  • Talus
    replied
    Re: unable to select xfi in audio options

    Deleting the BF2 settings directory in My Documents would have achieved that...

    I had the exact same problem and deleting that directory fixed it for me

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    Originally posted by bludothesmelly
    I dunno what it's deal is but i cannot select xfi as an option. I have the latest xfi driver, the game is patched up to 1.3 and it sill persists. Is there not a setting i can change in the files to fix this?
    Ok try setting the audio options back to the default (click the restore default button), then try the x-fi setting. When i got my x-fi it did the exact same thing and that fixed it

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    You could try reinstalling the game, and make sure your onboard sound drivers are uninstalled and disabled in the bios.

    Leave a comment:


  • bludothesmelly
    replied
    Re: unable to select xfi in audio options

    no regular headphones not usb

    Leave a comment:


  • disfigured
    replied
    Re: unable to select xfi in audio options

    This is a very long shot but......

    Are you using a set of USB headphones?

    If so there's a sound module in the cord that BF2 may be seeing rather then your X-fi.

    Happen to me when I bought my new Plantronics. Not being too much of an audiophile I didn't realize that the X-Fi (or any soundcard for that matter) is not able to access USB ports.

    Soon as I plugged the headphones in my sound sucked. I though it was the headphones. I went to screw around with the settings and couldn't access any EAX or X-fi options.

    Like I said, it's a really long shot, but it's the something Iv'e seen produce the exact same symptoms your describing.

    Leave a comment:


  • bludothesmelly
    replied
    Re: unable to select xfi in audio options

    Ive deleted the bf 2 directory that didnt solve it. It's been on game mode.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: unable to select xfi in audio options

    Hi.

    I've ended up here after trawling all over the place for an answer and hes not the only with the problem.

    I have an x fi fatality and it is definitely on game mode and yet bf2 won't recognise that it is there. When I try to select creative x fi on the audio menu it says you do not have the hardware to support this. And yet I'm using the front audio out jack on the breakout box for the x fi so...... huh?

    The x fi was installed before I installed bf2.

    I have bf2 patched to 1.3. I tried the latest creative drivers off their website for the x fi (3 july drivers) and yet it still won't recognise it. These drivers were supposed to fix things for bf2.

    I've also tried deleting the audio.con file out of my profile in the my documents folder as that was a suggestion I read elsewhere but I still can't get it to work.

    Slightly irritating, as I really like both the x fi and also bf2 - which I only recently got and wish I had gotten earlier... its a great game - I can see why its so popular.

    I apologise if this has been covered in depth here somewhere else but searching isn't bringing it up ... and I've tried ea forums, creative forums - so I have looked around but can never get a clear answer...

    Thanks.

    Xeno

    Leave a comment:

Working...
X