Announcement

Collapse
No announcement yet.

CS:Source will not launch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CS:Source will not launch

    I just tinkered with my little brother's computer and this is the current configuration:

    AMD Sempron 3000+ 2.0ghz processor
    1.5gb pc3200 ddr ram
    ~80gb hard drive

    256mb Radeon X1650 Video Card
    Driver Version: 8.411.0.0 (pretty recent i think)

    I decided to test it out with some CS: Source, so I installed steam and loaded cs:s on his comp from my steam account. Everything installs fine. When I launch the game, the monitor blinks (changing res) and I see the cs:s load screen for a second. Then it blinks again, and I am back at my desktop, steam staring at me like it did nothing wrong.

    also, in a probably related problem, the earthsim software that came with the ati card won't launch either...

    I've look around, and it doesn't seem to be a resolution issue (i've tried launching on many different res), and I am using DirectX 9.0c

    I don't know what the problem is. thanks for any help

  • #2
    Sometimes virii can cause this - have you run a full check? Don't bother if it's a new build. Do you get any error messages in the system logs (found in the Manage option when you right click My Computer)?

    Comment


    • #3
      It's not a completely new build, but i reformatted the hdd before i added more ram and the video card. So, I'm thinking it's not virus related.

      I looked in the event manager, and there seem to be quite a few errors. Most of them say this:

      The device, \Device\CdRom0, has a bad block.

      These are from when I was trying to install Far Cry from a badly scratched set of discs. They just refused to be read properly. The computer would start the install but at a certain place it would stop. So that is the bulk of the errors.

      Then there are a lot of warnings that say this, and they are from the same thing I believe.

      An error was detected on device \Device\CdRom0 during a paging
      operation.

      Then there is a DHCP error, a few MSIinstaller errors from the Far Cry incident, then there are two F-Secure errors -- something about files exceeding scanning time limit.

      Bleh. that is all. I am at a loss.

      Could it be that I have two different brands and sizes of RAM installed?

      Comment


      • #4
        freakofnature95 wrote..
        Could it be that I have two different brands and sizes of RAM installed?
        Very unlikely - I have that sort of configuration on many PCs. Sadly as I suspected, it's crashing out without an error. I'd be tempted to try an update to the very latest Catalyst drivers. There have been alot of issues like this since a recent Steam update - this could well be one of them.

        Comment


        • #5
          I just installed the card a few days ago and I downloaded the latest drivers from ATI, but I opted to not dl the Catalyst Software Suite.

          I figured that all I needed was the display driver if I didn't want to tweak the settings.

          I will download Catalyst and see what happens...

          Comment


          • #6
            Hey freak,

            Saw your post on Tech Forums too...my brother is having the same problems and like you, he also recently formatted AND put a new stick of RAM in!

            I think there's definately a connection there. We're gonna try a few things and let you know how it goes....

            Comment


            • #7
              I did get a similar thing with the ET:QW demo on Steam, which was annoying. I just deleted it though, which I wouldn't do with something I've paid for obviously. You shouldn't need the Catalyst CC, but it can be handy.

              Comment


              • #8
                Well, then we're back where we started. I have all the latest drivers installed, and I even updated the drivers for the mobo chipset.

                I looked at the video adapter properties and it lists the location of the card as: PCI bus 1, device 0, function 0. It's an AGP card.

                I don't know much about this, but is that the correct location for an AGP card?

                How can I tell that the card is not running in PCI mode?

                :::Update::::::::::::::::::::::::

                I went into the bios and changed the primary video adapter from PCI to AGP/onboard. No noticeable difference.

                CS:source still fails to launch.

                CS (not source) works fine, and I've installed and played Rise of Nations with no problems. However, I tried to play the World in Conflict Demo today, and the same exact problem is occurring.

                Thanks again and I am open to any further advice.

                Comment


                • #9
                  Alright. All is well.

                  I ended up having to go into safe mode and use a driver cleaning program to wipe all the stuff the ATI uninstaller leaves. The problem persisted at that point with the up to date driver (7.9). So I downloaded 7.7 from earlier this year and everything works beautifully.

                  Thanks for your assistance. That was no fun.

                  Comment


                  • #10
                    That was some good thinking, so the updated driver (or fragments of it) was causing the problem? The location of the AGP card on PCI bus 0 is normal - but it can be confusing as if you don't install your AGP driver for the motherboard, the graphics card often only works in PCI mode (ie slowly!).

                    Comment

                    Working...
                    X